PayPal Disruption
Incident Report for Selly
Resolved
The initial error has been resolved, but another issue with PayPal has appeared
Posted Oct 01, 2019 - 11:27 UTC
Investigating
PayPal is currently experiencing technical difficulties preventing some payments from being initiated.

https://www.paypal-status.com/history/eventdetails/10038
Posted Sep 30, 2019 - 20:53 UTC
This incident affected: Payments (PayPal).