Bitcoin payments not being processed
Incident Report for Selly
Resolved
This incident has been resolved.
Posted Jul 11, 2020 - 10:24 UTC
Identified
The issue has been identified and a fix is being applied.

Due to a server hardware failure, our Bitcoin cluster must re-sync with the Bitcoin network.
Posted Jul 10, 2020 - 22:27 UTC
This incident affected: Payments (Bitcoin).