PayPal Payment Anomalies
Incident Report for Selly
Update
We are continuing to investigate this issue.
Posted Jul 10, 2020 - 18:21 UTC
Investigating
We are investigating anomalies with PayPal payments including payments automatically being refunded and a classic PayPal checkout page being utilized.

This is a technical issue on PayPal's side and we are awaiting their resolution of the issue.
Posted Jun 14, 2020 - 21:09 UTC
This incident affects: Payments (PayPal).